Project

General

Profile

Bug #4482

JRE Exception Access Violations

Added by Oliver Soong about 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
10/21/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4482

Description

I've gotten a couple of these. All of Kepler just goes without warning. I have 2 error logs, which I will attach. I have no idea what causes it.

hs_err_pid1984.log (22.7 KB) hs_err_pid1984.log Oliver Soong, 10/21/2009 02:11 PM
hs_err_pid4284.log (16.9 KB) hs_err_pid4284.log Oliver Soong, 10/21/2009 02:11 PM

History

#3 Updated by Christopher Brooks about 10 years ago

These are Java issues. Both stack traces show the problem being in the
AWT-EventQueue thread.

The one with a useful stack trace has:

Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [ntdll.dll+0x21fb7]
C [msvcr71.dll+0x16b3]
C [msvcr71.dll+0x16db]
C [dcpr.dll+0x22a5]
J sun.dc.pr.Rasterizer.appendLine(FF)V
J sun.java2d.pipe.DuctusRenderer.createShapeRasterizer(Ljava/awt/geom/PathIterator;Ljava/awt/geom/AffineTransform;Ljava/awt/BasicStroke;ZZF)Lsun/dc/pr/Rasterizer;
J sun.java2d.pipe.DuctusShapeRenderer.renderPath(Lsun/java2d/SunGraphics2D;Ljava/awt/Shape;Ljava/awt/BasicStroke;)V
J sun.java2d.pipe.DuctusShapeRenderer.fill(Lsun/java2d/SunGraphics2D;Ljava/awt/Shape;)V
J sun.java2d.pipe.PixelToParallelogramConverter.fill(Lsun/java2d/SunGraphics2D;Ljava/awt/Shape;)V
J sun.java2d.pipe.PixelToParallelogramConverter.fill(Lsun/java2d/SunGraphics2D;Ljava/awt/Shape;)V
J sun.java2d.pipe.ValidatePipe.fill(Lsun/java2d/SunGraphics2D;Ljava/awt/Shape;)V
J sun.java2d.SunGraphics2D.fill(Ljava/awt/Shape;)V
J diva.canvas.toolbox.LabelFigure.paint(Ljava/awt/Graphics2D;)V
J diva.canvas.AbstractFigure.paint(Ljava/awt/Graphics2D;Ljava/awt/geom/Rectangle2D;)V
J diva.canvas.CompositeFigure.paint(Ljava/awt/Graphics2D;Ljava/awt/geom/Rectangle2D;)V
J diva.canvas.FigureLayer.paint(Ljava/awt/Graphics2D;Ljava/awt/geom/Rectangle2D;)V
J diva.canvas.CanvasPane.paint(Ljava/awt/Graphics2D;Ljava/awt/geom/Rectangle2D;)V
J diva.canvas.JCanvas.paint(Ljava/awt/Graphics;)V
J javax.swing.JComponent.paintChildren(Ljava/awt
/Graphics;)V

Searching google for:
sun.dc.pr.Rasterizer.appendLine dcpr
Comes up with two hits, neither of one is conclusive.

In general, if Kepler or Ptolemy is run and no JNI is used to load
Kepler or Ptolemy .dll and the JVM crashes, then it is a JVM bug.
It is very easy to crash the JVM if Kepler or Ptolemy uses JNI code
that loads a .dll or other shared library.

I'd probably close this one as it is a JVM bug, not a Kepler or Ptolemy bug.

#4 Updated by Oliver Soong about 10 years ago

Is there anything I can do to avoid this? I hate saving my work.

#5 Updated by Christopher Brooks about 10 years ago

The problem is likely specific to the machine, graphics card, OS and JVM.

Try upgrading the JRE that you are using.
The error was from JRE version: 6.0_14-b08, I think Java 1.6.0_15 is out?

Try using a Java 1.5 JRE instead of a 1.6.
Try using different resolutions.
Try using a different graphics card.
Try using a different machine? (drastic, I know).

#6 Updated by Chad Berkley almost 10 years ago

probably machine specific. not a kepler bug.

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4482

Also available in: Atom PDF