Project

General

Profile

Bug #4559

local repositories not showing up in components tree

Added by Oliver Soong over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
general
Target version:
Start date:
11/19/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4559

Description

Summary says it all. I'm at r21772, and the default workflows repository isn't in the components tree. Adding repositories doesn't do anything. I'm not even getting prompts to sign into KNB or DEV to cache data.

tpc01-buffalo-tb.kar (93.6 KB) tpc01-buffalo-tb.kar Oliver Soong, 11/20/2009 12:29 PM
tpc01-buffalo-tb run archive.kar (217 KB) tpc01-buffalo-tb run archive.kar Oliver Soong, 11/20/2009 12:29 PM

Related issues

Blocked by Kepler - Bug #4563: components search seems to be brokenResolved11/19/2009

Blocks Kepler - Bug #4512: missing entries with multiple copies of the same KAR file in a single repositoryResolved10/28/2009

Blocks Kepler - Bug #4608: ROML in KAR files not being shown at allResolved12/08/2009

Blocked by Kepler - Bug #4634: run archive causes NPE when building local repositoryResolved12/14/2009

History

#1 Updated by Aaron Aaron over 9 years ago

Yeah this is an interesting artifact of the new way the Component Library is built. I'm not sure if this is a bug or not yet. Thought I'd leave it that way for a little bit to see how people felt about it.

The way it works now is only paths to components in the library exist. So if you save a KAR file into the workflows folder then it will appear in the library. Otherwise the Workflows folder does not show up there. You will also notice the same behavior in the Ontologies. An ontology and ontology classes will only show there if there is a component in the local repositories that has been tagged with that SemanticType.

Anyway, use it this way for a little while and tell me what you think.

All the ontologies are now showing in teh Drop down box just above the component tree, so you can still see all of them there. And that list should now be getting updated when you add/remove a local repository.

#2 Updated by Oliver Soong over 9 years ago

Well, I'm now seeing the described behavior at r21780, but I'm missing a KAR. I've got one that's just the MOML and ROML, and another that's a run archive (MOML, ROML, run, pdf). I'm only seeing the run archive. This may be because the two KAR files share the same MOML and ROML (identical LSIDs), so this may be related to bug 4512.

#3 Updated by Aaron Aaron over 9 years ago

yeah, definitely still a little buggy, "ant clean-cache" will fix things if they get out of sync... I'll keep working on the bugs

#4 Updated by Oliver Soong over 9 years ago

I deleted the run archive from the repository and restarted Kepler, but the report archive (MOML and ROML only) still doesn't show. I was under the impression that Kepler would re-sync the repositories on startup, but just in case I did a clean-cache and it still says no components found.

#5 Updated by Oliver Soong over 9 years ago

This is slightly more complicated. I restarted Kepler again, and now both KARs show up in the components tree.

So starting from a clean-cache:
1. Only report archive (MOML & ROML) in the folder.
2. Added local repository. No components found.
3. Restarted Kepler. Component found.
4. Put run archive back in folder (MOML, ROML, run, & pdf).
5. Sources->Build. Only the 1 component found.
6. Restarted Kepler. Both components found.

#6 Updated by Aaron Aaron over 9 years ago

Oliver can you send me the kar you're having the problem with, I am having trouble reproducing this...

#9 Updated by Oliver Soong over 9 years ago

I'll see if I can make this happen with a simpler case. There have been unusual errors with this workflow in the past. Also, I'm still running r21788, so if there are changes that might affect this, please let me know.

#10 Updated by Oliver Soong over 9 years ago

I think this bug is partly due to bug 4512, partly due to the new hiding empty repositories "feature", partly due to changes in the KAR structure, and partly due to an ordering problem. There's also another slightly separate problem with local repository content not being added properly (differences between adding repositories from within Kepler and rebuilding the cache on Kepler startup), so that I have to close and restart Kepler before it finds any components.

So to explain. The tpc01 report archive contains an entity "ROML" and "tpc01-buffalo-tb" (the MOML). The tpc01 run archive contains those two entities as well as "RIO" and "WorkflowRun". Because of bug 4512, if the run archive is added to the cache first, then there is no new content in the report archive, and so the new functionality hides it.

If the report archive is added first, then the run archive adds some new content (but no new MOML or ROML) and is shown. I'm not sure why that triggers bug 4563.

There seems to have been a change in the way ROML is stored. If I generate a new pair of report and run archives, the report archive contains "test" (the MOML) and "test_ROML". On the other hand, the run archive contains "RIO", "WorkflowRun", and "ROML" in addition to "test" but no "test_ROML". The LSIDs for test_ROML and ROML also differ, even though the reports themselves never changed.

I think this is all due to the contents of MANIFEST.MF in the KARs and the names coming out of it. As far as I can tell, the names that show up in the components tree are the names in MANIFEST.MF truncated to the first dot (.). The name for the ROML used to be identical between the run and report archives, but now it differs. Also, the tpc01 run archive seems to contain 2 entries for the ROML with different names but the same LSID. The test run archive seems not to have that problem.

#11 Updated by Oliver Soong over 9 years ago

Fixing bug 4512 solves part of the problem, but some others remain and there are some new ones. I'm still following the instructions from Comment 5.

The problem shown in step 2 (no components after adding local repository) still exists.

In step 3, the component is found as before, but now it only contains the MOML, even though the KAR file itself has both MOML and ROML.

In step 6, both components are found and both contain MOML, but neither show the ROML, even though it is definitely in the KAR.

#12 Updated by Oliver Soong over 9 years ago

I think the missing reports are part of a larger problem, which I've filed separately as bug 4608. The other problem with KARs not showing up in the repository until Kepler restarts is still there.

#13 Updated by Oliver Soong over 9 years ago

At this point, KAR files in local repositories are not ending up in the components tree when they are first added. They will show up on a Kepler restart, though. Rebuilding the tree also does not seem to help.

#14 Updated by Aaron Aaron over 9 years ago

Oliver, can you recheck if this is still happening and close this bug if it is covered in other bugs or succinctly state again what the issue is... Thanks!

#15 Updated by Oliver Soong over 9 years ago

Not sure when the last bit got fixed, but it seems to be working now.

#16 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4559

Also available in: Atom PDF