Project

General

Profile

Bug #4872

listen to director throws error

Added by Oliver Soong over 9 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
director
Target version:
Start date:
03/05/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4872

Description

Add an SDF Director and the Tools->Listen to Director. An error pops up on the console:

Error creating action for class: org.kepler.gui.RunWithFeedbackChkBoxAction : null
Error creating action for class: org.kepler.gui.RunWithFeedbackChkBoxAction

I'm not sure if this causes problems or not.


Related issues

Is duplicate of Kepler - Bug #4911: org.kepler.gui.RunWithFeedbackChkBoxAction exception message.Resolved03/29/2010

Has duplicate Kepler - Bug #5450: Menu: Help -> Kepler Documentation causes IllegalArgumentExceptionResolved08/05/2011

History

#1 Updated by Derik Barseghian over 9 years ago

I believe this is more general; I've seen this error periodically lately when using other context menus.

#2 Updated by Derik Barseghian over 9 years ago

This also happens when you use these context menus:

Open Actor
Documentation => Display
Listen to Actor

I'm also not sure if it causes any problems (so far I haven't seen any)...

#3 Updated by Oliver Soong over 9 years ago

I'm also seeing something like this when I run, sometimes. I get:

java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
[...]
at org.kepler.gui.MenuMapper.getActionFor(MenuMapper.java:261)
[...]
Caused by: java.lang.IllegalArgumentException: RunWithFeedbackChkBoxAction constructor could not get actions for DEBUG->ANIMATE EXECUTION or DEBUG->STOP ANIMATING
at org.kepler.gui.RunWithFeedbackChkBoxAction.<init>(RunWithFeedbackChkBoxAction.java:123)

#4 Updated by Oliver Soong over 9 years ago

Oh, and it doesn't seem to cause any serious problems.

#6 Updated by Daniel Crawl about 8 years ago

duplicates 5450

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4872

Also available in: Atom PDF