Project

General

Profile

Bug #5603

ant run -Dworkflow=${HOME}/Downloads/SimpleLoop.kar fails

Added by Christopher Brooks over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
build system
Target version:
Start date:
05/08/2012
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5603

Description

ant -p says:

run Compile, then run Kepler along with the modules in modules.txt. Use -Dworkflow=model.xml to run a model.

When I run:
ant run -Dworkflow=${HOME}/Downloads/SimpleLoop.kar

I get

[run] RunClasspath:ptolemy /Users/cxh/src/kepler/ptolemy/src
[run] Set environment variable: PATH = /opt/local/bin:/opt/local/sbin:/Users/cxh/.local/bin:/Libra\
ry/Frameworks/Python.framework/Versions/2.7/bin:/opt/subversion/bin:/System/Library/Java/JavaVirtualMach\
ines/1.6.0.jdk/Contents/Home/bin:/usr/local/texlive/2011/bin/x86_64-darwin/:/Applications/MATLAB_R2012a.\
app/bin:/usr/local/bin:/opt/local/bin:/opt/local/sbin:/Users/cxh/.local/bin:/Library/Frameworks/Python.f\
ramework/Versions/2.7/bin:/opt/subversion/bin:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Content\
s/Home/bin:/usr/local/texlive/2011/bin/x86_64-darwin/:/Applications/MATLAB_R2012a.app/bin:/usr/local/bin\
:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/local/git/bin:/usr/texbin:/Users/cxh/src\
/kepler/r/lib:/Users/cxh/src/kepler/common/lib:/Users/cxh/src/kepler/common/lib/ptolemy/matlab
[run] Set environment variable: R_HOME = /Library/Frameworks/R.framework/Resources
[run] Checking for patches...
[run] Found OS Extension file: /Users/cxh/src/kepler/apple-extensions/module-info/osextension.txt
[run] loading OS extensions for OS Mac OS X with class org.kepler.osx.KeplerOSXExtension
[run] Building Kars...
[run] INFO (org.kepler.Kepler:_trySaveOutModuleTree:539) Module configuration has changed, deleti\
ng cache
[run] Ran additional initialization for module core from class org.kepler.module.core.Initialize
[run] Ran additional initialization for module gui from class org.kepler.module.gui.Initialize
[run] Executing ptExecuteApplication
[run] Kepler Initializing...
[run] Unsupported file type or connection not available: file:/Users/cxh/Downloads/SimpleLoop.kar
[run] Done.
[run] Ctrl-c to exit.
[run] Ran additional cleanup for module core from class org.kepler.module.core.Shutdown

In addition, the process hangs and I have to type control-c.

This makes it annoying to use Kepler to check out bugs and open models.

ant run -Dworkflow=SimpleLoop.kar
also fails.

Basically, it looks like -Dworkflow does not work?


Related issues

Is duplicate of Kepler - Bug #5381: run-workflow does not work for KAR filesResolved04/22/2011

History

#2 Updated by Daniel Crawl over 7 years ago

ant run -Dworkflow works for kars now.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5603

Also available in: Atom PDF