Project

General

Profile

Bug #1340

define and implement kepler archive file format (kar)

Added by Chad Berkley almost 16 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
core
Target version:
Start date:
02/09/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1340

Description

we should implement a packaging function similar to what we have in metacat
where if you want to ship a pipeline to someone else, kepler would find all the
actors that aren't in the standard library and zip them up with the workflow
moml. This would make it easy for simple sharing of workflows. eventually, we
could have it automatically upload these to the grid as well.


Related issues

Is duplicate of Kepler - Bug #2025: provide workflow and results in some publishable formatResolved03/11/2005

Blocked by Kepler - Bug #1895: remote actor repositoryResolved01/20/2005

History

#1 Updated by Chad Berkley almost 15 years ago

we decided in kansas that we need a kepler archive file (kar) that will
encapsulate data and services as well as the workflow and metadata. We talked
about this further in juneau 1/05

#2 Updated by Chad Berkley over 14 years ago

The KSW format has been changed several times. It's current incarnation is 100%
compatible with the current MoML DTD. I have sent it to Shawn and Christopher
for them to validate that it is 100% MoML compatible.

There is now an automated class that will create a KSW file for a single actor.
Need to work on encapsulating an entire workflow. The KSW for a single actor
can be loaded dynamically at kepler startup simply by putting the ksw file into
the kepler/ksw directory.

#3 Updated by Chad Berkley over 14 years ago

I forgot to mention, that currently, even though the ksw metadata contains
semantic annotations, they are still using the old system. This will change
when we implement the getAllObjects() method that Shawn needs to complete the
new semantics system.

#4 Updated by Matt Jones about 14 years ago

Mostly complete. Cleaning up loose ends dealing with class loading.

#5 Updated by Matt Jones about 14 years ago

  • Bug 2025 has been marked as a duplicate of this bug. ***

#6 Updated by Matthew Brooke about 14 years ago

reclassified to core

#7 Updated by Chad Berkley about 14 years ago

The kar format has been specified and kar files are currently being used to load
actors into kepler. it was recently decided that sine we don't have time to do
dynamic class loading, we are going to package only moml into the kar files and
just use kar files for transporting "configured moml actors". The use of kar
files as an archive format is being postponed until after release 1.0.

#8 Updated by Chad Berkley almost 14 years ago

changing the milestone to A9. The kar file loading is working but i'm not going
to be able to have the kar file creation (user clicking on a wf or actor and
choosing "create kar file") working by A8. Also changed the severity to major
instead of blocker since this is no longer a blocker.

#9 Updated by Chad Berkley almost 14 years ago

This is now mostly working, but there are still issues with adding annotations
to the actor. Shawn and I are going to work on this the Thursday after the
Davis Kepler meeting and hopefully resolve this bug.

#10 Updated by Chad Berkley over 13 years ago

This is now complete.

#11 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1340

Also available in: Atom PDF