Project

General

Profile

Bug #2031

browse/filter for data and data nodes on the ecogrid and local

Added by Laura Downey over 14 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
semantics
Target version:
Start date:
03/11/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2031

Description

provide browsing and filtering mechanims for data and data nodes on the ecogrid


Related issues

Is duplicate of Kepler - Bug #2112: add default data browse heirarchyResolved06/10/2005

Is duplicate of Kepler - Bug #2124: provide mechanism for user to see available nodes on ecogridResolved06/13/2005

Has duplicate Kepler - Bug #2143: fix functionality and GUI issues with query builderResolved07/05/2005

History

#1 Updated by Matt Jones over 13 years ago

Request not specificed in enough detail. EcoGrid nodes can already be obtained
via searching in the Sources dialog.

Data sets from the various provides are too numerous to browse in a flat list.
However, its possible we could browse them using an inverted index based on
semantic classifications. Expanding on an ontology category in the tree would
show all of the local data sets under that category and launch a query for
remote data sets under that category which would be added as the search returned.

This requires ontology-based search on ecogrid nodes which we do not yet have.

#2 Updated by Matt Jones over 13 years ago

  • Bug 2112 has been marked as a duplicate of this bug. ***

#3 Updated by Matt Jones over 13 years ago

text from bug #2112:

In the data tab/pane, add/display a default dat browse heirarchy (similar to
component browse heirarchy shown in actor tab)
[decision from May 2005 Estes Park mtg]

#4 Updated by Matt Jones over 13 years ago

  • Bug 2124 has been marked as a duplicate of this bug. ***

#5 Updated by Jing Tao over 13 years ago

This bug can be merged into bug 2143

  • This bug has been marked as a duplicate of 2143 ***

#6 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2031

Also available in: Atom PDF