Project

General

Profile

Bug #2143

fix functionality and GUI issues with query builder

Added by Chad Berkley about 14 years ago. Updated about 13 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
data access
Target version:
Start date:
07/05/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2143

Description

The query builder needs to be evaluated for broken functionality and the UI
needs to be looked at and evaluated by laura. jing and efrat agreed to look at
this at the june 05 kepler meeting.


Related issues

Is duplicate of Kepler - Bug #2031: browse/filter for data and data nodes on the ecogrid and localResolved03/11/2005

Is duplicate of Kepler - Bug #2144: fix functionality and GUI issues with query builderResolved07/05/2005

Blocked by Kepler - Bug #1881: Add intermediate pane to Query BuilderResolved01/20/2005

History

#1 Updated by Matt Jones over 13 years ago

  • Bug 2144 has been marked as a duplicate of this bug. ***

#2 Updated by Matt Jones over 13 years ago

Issues submitted by Efrat Frank regarding Query Builder in Kepler.
--------------------

1. No conversion available from sql to xml query representation, thus
changes made through the sql tab don't get reflected. Perhaps the xml
representation is redundant here..

2. Sometimes updates don't get reflected the first time around, but only
after reopenning the query builder and re-updating.
E.g. when changing the intermediate tab:
The first time creates the following xml representation:
() <query advanced="false">
</query>
Only the second time, the updates get reflected, given that the
current sqlDef attribute value is (
)). Perhaps (*) should be set as the
default initial sqlDef.

3. Confusions between changes made through various tabs.
Usually only the last used tab's changes get reflected.
Sometimes when changing the standard tab along with other tabs, only
the standard tab changes get reflected (this seems to be related to
problem 2, and could probably be solved using (*) as the default
expression).
Going between advanced tabs to the standard tab, causes several
representation exceptions (understandable, as some parts cannot be
evaluated in the standard tab - should not allow going backword between
the tabs once the more advanced tab is updated).
On the other hand, there may also be conflicts between the tabs (the
intermediate and advance), so one of them needs to be eliminated.

4. When traversing between tabs to the SQL tab, the query in the SQL
doesn't reflect the user current modifications, the changes are
reflected only after commiting.

5. Sometimes after several modifications (in the advanced and
intermediate tabs) the query builder no longer loads. It seems to be
related to exception when parsing the xml query representation.

6. The operator criterion in the standard tab doesn't get reflected in
the xml representation.

#3 Updated by Matt Jones over 13 years ago

Query builder needs to be simplified and tested, making sure that all advertised
features work reliably for the alpha8 target.

#4 Updated by Jing Tao over 13 years ago

  • Bug 1881 has been marked as a duplicate of this bug. ***

#5 Updated by Jing Tao over 13 years ago

  • Bug 1894 has been marked as a duplicate of this bug. ***

#6 Updated by Jing Tao over 13 years ago

  • Bug 2031 has been marked as a duplicate of this bug. ***

#7 Updated by Jing Tao over 13 years ago

In the kepler meeting of Davis, we decieded to simplify the query builder. Now
it only has standard panel and sql panel. And some bugs such as sql panel could
display sql string, and "where" clause couldn't be adding to sql without hitting
"enter" key, were fixed. I talked with Dan and Efrat - the main users of
QueryBuilder, it seems current status is fine to them.

#8 Updated by Laura Downey over 13 years ago

Proposed minimal changes for Release 1.0 are:
give the dialog a title - Query Builder
-remove menus (no menus in dialogs)
-change "Standard" to "General" on first tab - this will mesh with other
dialog designs coming down the road
-on Standard/General tab:
*remove the expandable/collapsible tiny arrowheads and replace with thick
movable separator bar
*remove bottom data tab and replace with drop down box listing available
tables, this should go at the top of the top section right next to "Available
Table Schemas:" -
the current design is confusing to have tabs at bottom and
top and it does not support data sources with large numbers of tables which
would produce large numbers of tabs at the bottom of the top half of this
dialog
*rename "Display" to "Include in Query" and make that the first column with
the default checked
*on the radio buttons, make things sentence case and also reword as follows:
Meets ALL included conditions listed below. Meets ANY included conditions
listed below.
*all column headings should be centered for consistency
*display drop down box indicators in table cells that have drop down choices
so user doesn't have to discover that there are choices available (this is the
standard design for other tables to be included later)
-on SQL tab, make it grey to indicate that this can't be edited but is merely
for display purposes

#9 Updated by Jing Tao about 13 years ago

The aboved tasks were done.
I added more stuff:
1. Okay and Cancel buttons
2. New right click menu to delete existed row.

#10 Updated by Dan Higgins about 13 years ago

newest (beta1) release resolves thess issues

#11 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2143

Also available in: Atom PDF